Diff: LinuxOnToshibaPortege610CT

Differences between current version and predecessor to the previous major change of LinuxOnToshibaPortege610CT.

Other diffs: Previous Revision, Previous Author

Newer page: version 28 Last edited on March 1, 2012 11:03 pm by PhilHollenback
Older page: version 23 Last edited on January 28, 2009 4:28 pm by PhilHollenback Revert
@@ -65,9 +65,9 @@
 to /etc/modules.conf. Remember that for debian, you need to actually add that line to /etc/modutils/aliases, then rebuild /etc/modules.conf with ''update-modules''. 
  
 !Mouse 
  
-The Accupoint mouse works fine with the PS/2 driver. Only two buttons, so you have to turn Emulate3Buttons on in XFree86-config. One oddity I noticed was that the mouse skipped all over the place when run through /dev/psaux in XFree86. I installed gpm and the mouse worked fine on the console, so it's a X problem. The solution was to use gpm for the mouse driver under XFree86: 
+The Accupoint mouse works fine with the PS/2 driver. Only two buttons, so you have to turn ~ Emulate3Buttons on in XFree86-config. One oddity I noticed was that the mouse skipped all over the place when run through /dev/psaux in XFree86. I installed gpm and the mouse worked fine on the console, so it's a X problem. The solution was to use gpm for the mouse driver under XFree86: 
  
 * edit /etc/gpm.conf and add the line repeat_Type=raw 
 * edit /etc/X11/XFree86-config-4 and set the mouse device to /dev/gpmdata. Leave the driver as "PS/2". 
 * Restart gpm and X. 
@@ -112,28 +112,10 @@
  
 As of early 2009 I no longer have this laptop so will be unable to answer any questions about it. Sorry! 
  
 ----- 
-<?plugin RawHtml  
-<script>  
-var idcomments_acct = '011e5665a1128cdbe79c8077f0f04353';  
-var idcomments_post_id;  
-var idcomments_post_url;  
-</script>  
-<span id="IDCommentsPostTitle" style="display:none"></span>  
-<script type='text/javascript' src='http://www.intensedebate.com/js/genericCommentWrapperV2.js'></script>  
-?>  
------  
-<?plugin RawHtml  
-<center>  
-<script type="text/javascript"><!--  
-google_ad_client = "pub-5011581245921339";  
-google_ad_width = 728;  
-google_ad_height = 90;  
-google_ad_format = "728x90_as";  
-google_ad_channel ="";  
-//--></script>  
-<script type="text/javascript"  
- src="http://pagead2.googlesyndication.com/pagead/show_ads.js">  
-</script>  
-</center>  
-?>  
+  
+CategoryGeekStuff  
+  
+CategoryBlog  
+  
+CategoryLinuxStuff  

current version

I have Debian 3.0 (woody) running beautifully on a very tiny, very old laptop: the Toshiba Portege 610CT:

(no, that's not my system, it's a pic I stole from the internet)

In the grand tradition of Linux enthusiasts everywhere, I'm donating my notes to the public domain in the hopes that others find them useful.

The System

First, a few words about the system: This is a Pentium-90 machine with 40MB of RAM, a 1.6GB hard drive, and an absolutely stunning 89.1" 640x480 active color screen. This thing was absolutely the hottest executive mini-laptop for 1995. The system is about 80% of the size of a regular laptop of the era. You can hold it in one hand and type with the other, if you're a giant like me.

The battery on a laptop of this age is very likely dead. You can purchase new ones (as of 2002), but the price is around $220!. That's because it's a custom Lithium-Ion battery. Ebay to the rescue: I got a new in the box battery for $20. Run time is around 3 hours 30 minutes.

Installing software on this system is tedious, as the only drive is an external 3.5" floppy. It may be possible to use a pcmcia cd-rom drive with this system, but I haven't tried it. Thus, the best install option is to get a PCMCIA network card (I used a 3com 3c589D) and a decent internet connection. Then, you can get the system running with the six Debian install floppies and do the rest of the install over the internet. Warning: this is a very slow process. Expect to spend all day installing and upgrading the machine.

The system originally came with something like 8MB of RAM and a 500MB hard drive. It's probably not useful unless you upgrade those first. The max RAM is 40MB, and the memory module is proprietary, so you may have to scrounge quite a bit to get one. The hard drive is a standard 2.5" one, although only the slimmest drive will fit. I think you could go to at least an 8GB hard drive without problems. Note also that the PCMCIA slot is 5v only - some modern PCMCIA net cards are 3.3v, and won't fit (or work) in this system. Also, you need a real 16 bit PCMCIA card, not a 32 bit Cardbus card.

If you don't have the external floppy drive, I really have no idea how you are going to get anything installed. Feel free to tell me if you do manage it.

The Install

For the install, I downloaded the 6 standard (vanilla) Debian 3.0 1.44MB floppy images from www.debian.org. This includes the root disk, the rescue disk, and driver disks one through four. Installation is very straightforward, primarily because all the hardware gets detected automatically. The Chips & Technology F65546 video chip works fine at 640x480, 16M colors. However I've only had success with the 4.1.0 version of XFree86 (the one that comes with Debian 3.0). Attempts to use the 4.2.1 xfree86 from testing result in a complete system lockup after a minute or so of graphics activity. I have not tried XFree86 3.0 yet.

As I mentioned earlier, the install takes a looong time (What do you want with a Pentium 90?). I installed KDE but skipped Gnome - more on that later. Generally you can install a pretty complete system in about 1.2GB of space. I used a separate 25MB boot partition just in case lilo had problems with the larger hard drive, but I'm not sure if that's required. I also set the system to 60MB of swap, which seems to work well - I swap a lot, but rarely do I see swap usage go above 25%. Free memory usually runs at about 1MB.

After the install, I edited /etc/apt/sources.list and replaced the "stable" branch with the "testing" branch, and then ran "apt-get upgrade". Now as I mentioned earlier, testing includes the 4.2.1 XFree86, which you don't want. I believe you can instruct apt to "hold back" packages for situations like this, but I'm unsure about how to do it. What I ended up doing was running the whole upgrade, then removing the 4.2.1 XFree86 packages and reinstalling the 4.1.0 packages. You can do this by putting both testing and stable apt sources in your sources.list, and then selecting which one you want on the command line with the "-t" switch to apt-get. So to install the packages from stable, I used "apt-get -t stable install x-window-system".

Configuration

You don't need to do anything special with XFree86 to get video running - autodetect works great. You might want to use a virtual screen of 800x600 because a lot of modern programs are just not designed to fit in a 640x480 desktop. For a desktop, I'm using the fvwm window manager and konqueror 3.1.3 (install from unstable). The whole Gnome or KDE desktop environment is just too massive. Gnome in particular is very bloated these days. Don't bother with trying to run mozilla - it locked up the system when I ran it. The stripped-down Mozilla browser Firebird (package mozilla-firebird) does work, but is significantly slower than Konqueror. You need the 3.x Konqueror because it has support for SSL and it's rendering is much improved. To get this setup, edit your user X startup file .xsession to look like this:

konqueror -geometry 640x480+0+0 &
fvwm

and set that file to mode 700. Note that you will have to install konqueror and fvwm manually.

Another valuable package is toshutils. It provides a set of tools to manage the Toshiba laptop settings. I suggest you run the included wmtuxtime on your X desktop. wmtuxtime provides battery runtime info and direct access to the Toshiba utils for things such as turning the system beep on or off.

I also upgraded the kernel to version 2.4.21, since Woody comes with 2.2.20. This was as easy as adding the lines

deb http://mirrors.kernel.org/debian/ unstable main non-free contrib
deb-src http://mirrors.kernel.org/debian/ testing main non-free contrib

to /etc/apt/sources.list, running apt-get update, and then using apt-get to install the following packages:

kernel-image-2.4.21
kernel-headers-2.4.21-4-586tsc
kernel-pcmcia-modules-2.4.18-1-586tsc

As I mentioned earlier, autodetect works fine for XFree86. However, if you have problems with that for some reason, here's my XF86Config.

Sound

This machine comes with an ESS 688 audio chip. To configure it, simply add the line

alias sound-slot-0 sb

to /etc/modules.conf. Remember that for debian, you need to actually add that line to /etc/modutils/aliases, then rebuild /etc/modules.conf with update-modules.

Mouse

The Accupoint mouse works fine with the PS/2 driver. Only two buttons, so you have to turn Emulate3Buttons on in XFree86-config. One oddity I noticed was that the mouse skipped all over the place when run through /dev/psaux in XFree86. I installed gpm and the mouse worked fine on the console, so it's a X problem. The solution was to use gpm for the mouse driver under XFree86:

  • edit /etc/gpm.conf and add the line repeat_Type=raw
  • edit /etc/X11/XFree86-config-4 and set the mouse device to /dev/gpmdata. Leave the driver as "PS/2".
  • Restart gpm and X.

Then the mouse works smoothly under X.

The rubber top for the Accupoint was completely worn out. I was unable to find another one, so I used an IBM trackpoint top instead. Unfortunately the Accupoint uses a round mounting hole while the Trackpoint uses a larger square one. Thus, the top did not stay on. I found that a small piece of gaff tape wrapped around the shaft was enough to keep the Trackpoint top firmly in place.

War Driving

I've had some success using this machine to sniff out open wireless access points. I've got a Wavelan Gold PCMCIA 802.11b card, which uses the orinoco_cs driver. By default, this driver does not allow WiFi sniffing. You need to get the orinoco patch and apply it against the pcmcia-cs source. Then, install the wireless-tools package. You can tell if you have the right driver installed by running iwpriv out of that package. If the fixed driver is running, iwpriv will report that the device has the "monitor" ioctl.

Then install Kismet from testing or unstable. Edit /etc/kismet/kismet.conf and choose capture type pcap and card type orinoco. Then when you run Kismet, it should start printing info about wireless lans it sees.

This is unfortuantely only halfway working for me. Kismet starts up and sees a few packets, but then the orinoco_cs driver starts spewing NETDEV WATCHDOG: eth0: transmit timed out messages until I remove and reinsert the wireless card. So, looks like there may be a driver problem. I am using the latest orinoco driver (.13b) and the latest pcmcia package (3.2.4), so perhaps changing versions will help. Until then, network sniffing remains tantilizingly close.

It might be useful to try a card that uses a different driver to see if it is indeed a driver issue.

Odds and Ends

I notice every few days that when I start the system up, the keyboard is scrambled. Pressing "d" prints "dx", pressing "e" prints "es", etc. It seems the keyboard controller gets confused about which key is which. This problem seems to go away after a few reboots. I would like to get a replacement keyboard to test this next time it happens.

Update 9/6/03: I acquired a replacement keyboard and installed it. The proble has not gone away, so I don't know what's going on. It now occurs about 70% of the time, so I'm using an external keyboard instead. Makes the system not so portable, but it's ok for home use. Next step is to buy a broken 610CT off ebay for parts and swap the motherboard to see if that cures the problem.

Update 11/3/03: I swapped the keyboard a couple months back, and that didn't fix the problem. It did however give me a keyboard with snappier mouse and key response, so that was good.

Oddly, after several weeks of the key swapping problem, it just disappeared and hasn't come back again. I guess there's some marginal electronics somewhere in the machine.

APM suspend seems to work ok if you suspend for an hour or less. The machine often doesn't wake up after longer suspends. It's a good idea to install ext3 so you have a journalled filesystem when you have to cycle the power to clear this.

The system fan never comes on. Some posts in the linux-on-portege list suggest that the fan is software controlled and won't come on unless a program tells it to. The fan program which comes with toshutils reports that there is no fan installed on my 610CT.

Thus, the system seems to run pretty warm all the time. Not sure if that will cause permanent damage.

Links

The first place to check for Linux laptop info is Linux On Laptops.

The linux on portege also contains a lot of (toshiba-specific) linux laptop info.

Note that as of November 2006 I still have this laptop but I haven't turned it on in over a year.

As of early 2009 I no longer have this laptop so will be unable to answer any questions about it. Sorry!


CategoryGeekStuff

CategoryBlog

CategoryLinuxStuff



Our Founder
ToolboxClick to hide/show